]> gitweb.factorcode.org Git - factor.git/blobdiff - shell.nix
sequences.extras: Add a couple words for prepending spaces to lines
[factor.git] / shell.nix
index 83c3743c9c95f1a3ad57b26cf4e3ff31a535c9b0..f9d896259e7b7edee0424f0a3a917aaf54234bee 100644 (file)
--- a/shell.nix
+++ b/shell.nix
@@ -31,16 +31,22 @@ in
     makeWrapper
   ];
   shellHook = ''
+    # Set Gdk pixbuf loaders file to the one from the build dependencies here
+    unset GDK_PIXBUF_MODULE_FILE
+    # Defined in gdk-pixbuf setup hook
+    findGdkPixbufLoaders "${pkgs.librsvg}"
+
     wrapFactor () {
     [ -n "$1" ] || { printf "Usage: wrapFactor <factor-root>" ; return; }
     local root="$(realpath $1)"
     local binary="''${root}/factor"
     local wrapped="''${root}/.factor-wrapped"
     # Remove the wrapped binary if a new VM has been compiled
-    ${lib.getBin file}/bin/file $binary |grep ELF >/dev/null && rm -f "$wrapped"
+    ${lib.getBin file}/bin/file "$binary" |grep ELF >/dev/null && rm -f "$wrapped"
     # Restore the factor binary if it was already wrapped
     [ -e "$wrapped" ] && { mv "$wrapped" "$binary" ; }
     wrapProgram "$binary" --prefix LD_LIBRARY_PATH : ${runtimeLibPath} \
+      --set GDK_PIXBUF_MODULE_FILE "$GDK_PIXBUF_MODULE_FILE" \
       --argv0 factor
     ln -sf "''${root}/factor.image" "''${root}/.factor-wrapped.image"
     }