]> gitweb.factorcode.org Git - factor.git/blob - shell.nix
Simplify nix shell environment
[factor.git] / shell.nix
1 { pkgs ? import <nixpkgs> {} }:
2 with pkgs;
3 let
4   mkClangShell = mkShell.override { stdenv = clangStdenv; };
5   runtimeLibs = with xorg; [
6     glib
7     pango cairo
8     gtk2-x11
9     gdk_pixbuf
10     gnome2.gtkglext
11     pcre
12     mesa_glu
13     freealut
14     openssl
15     udis86 # available since NixOS 19.09
16     openal
17   ];
18 in
19 (mkClangShell {
20   name = "factor-shell-env";
21   LD_LIBRARY_PATH = "/run/opengl-driver/lib:${lib.makeLibraryPath runtimeLibs}" ;
22   buildInputs = runtimeLibs ++ [
23     # for building factor
24     git
25     curl
26   ];
27 })